26 enero 2005

:: Redes en Maracena

Fuí a Granada para arreglar diversos problemas en la red wireless que monté hará unas semanas, una gozada las redes wireless como siempre pero con fallos aún. La red de la que os hablo es un dominio con un único controlador y unas cuantas estaciones de trabajo. El principal problema con el que me encontré fue que el controlador de dominio no respondía a las peticiones de la estaciones evitando que determinados equipos recibiesen su dirección ip a través del dhcp y poder realizar transmisión de datos y otros en cambio no podían agregarse al dominio en cuestión. Pensé en un principo en la encriptación WEP pero era correcta lo que me hizo pensar en graves problemas con el servidor de dominio. De esta manera me puse manos a la obra.\r\n\r\nEl servidor (DC) no respondía por lo que lo sustituí por otro servidor aún más potente y con mejores prestaciones, le instale un Windows 2003 Enterprise, le promocioné a dominio (dcpromo) y luego configuré determinados servicios como Wins y DNS, dejando sin agregar el servicio de DHCP ya que posiblemente el fallo principal y todos los problemas vinieron por instalarlo en el antiguo controlador de dominio que seguramente entraba en conflicto con el DHCP habilitado del Punto de Acceso (PA). Las estaciones realizaban peticiones y el envío de ip por parte del DC y del PA entraban en lucha ;) Así pues no instalé este servicio, configurando posteriormente de nuevo el DHCP del PA. Para los que les pase como a mí, nunca instalar el DHCP del servidor si el PA tiene esta posibilidad, el correcto funcionamiento vendrá si habilitamos el DHCP del PA. Si habilitamos el DHCP del servidor y no el del PA deberiamos poner en el archivo hosts las ip de los equipos "a fuego" como se suele decir, para evitar posibles fallos por pérdidas de conexión entre el PA y tarjetas wireless.\r\n\r\nSeguidamente añadí las diferentes estaciones al dominio, primeramente comencé con la estación que no se agregaba al dominio teniendo como DC al anterior servidor y tras resetear la ip fija en las propiedades TCP/IP dejándola automática y haciendo un ipconfig /renew en la línea de comandos, se le asignó una ip correcta dentro del rango permitido dentro del DHCP del PA. Las demás estaciones tras esto fueron pan comido y unicamente tuve que realizar de nuevo el paso de agregarlas a dominio.\r\n\r\nTras tirarme después casi dos horas pasando datos de un servidor a otro, ya estaba lista la red a falta de la configuración de las impresoras, la primera de ellas una HP a color funcionó sin problemas al estar conectada al puerto LPT1 del servidor. La siguiente máquina, una Ricoh, iba conectada a una tarjeta LPT adicional con otro tipo de funcionalidades, aunque su configuración no fue díficil si lo fue a la hora de encontrar los drivers por internet ya que la empresa fue absorbida por otra y estaban descatalogados (el eterno problema de las tarjetas de terceros no muy conocidos), aunque finalmente di con ellos y funcionando que es gerundio :)\r\n\r\nVeremos cuanto dura...